Sahara's WebLog

日記のような、備忘録のような、うらみつらみのような、自慢のような…。

eclipse で Unable to resolve target 'android-17' エラー

久しぶりにeclipseを起動したら「Unable to resolve target ‘android-17’」というエラーが出た。
Unable_to_resolve_target-01

ちなみに以下、環境はWindows 7 PRO 64BIT、the Eclipse ADT Bundle のバージョンは「adt-bundle-windows-x86_64-20140702」だ。

早速検索すると、要は該当するAPIがインストールされてないということのようだ。
自分で作ったプロジェクトならターゲットは意識しているからAPIが用意してあるか確認するわけだが、人様のプロジェクトを拝借するときはこういうことが起こるというわけだと理解した。
いずれにしても「SDK Manager.exe」を起動する。
起動しない。
一瞬DOS窓が開くが、表示を見る間も無く閉じる。
また検索すると、java.exeの呼び方がおかしくなってるからとのこと。
気になって調べてみたら、このシステムにはjava.exeが5つもある。
Unable_to_resolve_target-02
こんなに必要なのか、それとも本来は1つでいいのかすら分からないが、要は、呼ぶべきjava.exeと違うjava.exeが呼ばれてしまって「SDK Manager.exe」が起動しないんだそうだ。
この場合は、
adt-bundle-windows-x86_64-20140702¥sdk¥tools¥android.bat
を起動すればいいらしい。
すると、やっと「Android SDK Manager」が起動して、確かに件のAPIはまだインストールされていなかったことが確認できる。
Unable_to_resolve_target-03
チェックを入れてインストールする。

このエントリーをはてなブックマークに追加

Posted under: インストール


コメントを残す

メールアドレスが公開されることはありません。

Time limit is exhausted. Please reload CAPTCHA.